Radio module initialising

Bigpanman

Novice Member
Joined
May 14, 2022
Messages
4
Reaction score
0
Points
1
Sk15
Driving
MG HS PHEV
Hi has anyone had any problems with the radio module initialising my head until went into engender mode when I started the car I just pressed exit and now it will not connect the radio it just keeps saying radio module initialising. I have been back to my mg dealers they said its a known fault and told me that they have to send it to mg headquarters. They then said they will not do the repair under warranty as I had tampered with the unit.
 

Alb

Moderator
Joined
May 11, 2021
Messages
1,847
Reaction score
2,063
Points
146
Gloucestershire
Driving
MG5 EV
I wouldn't see entry into engineer mode as an issue regardless of whether it happened deliberately or accidentally as long as nothing was actually changed.
 

sky0000547

Active Member
Joined
May 25, 2021
Messages
156
Reaction score
53
Points
28
South Yorkshire
Driving
MG HS PHEV
I had the fault. Dealer fixed under warranty. Didn’t need to send it off, had the car back the next day.
 

Attachments

  • 234BBE7D-6D58-461F-8BF5-23FFF9C23195.jpeg
    234BBE7D-6D58-461F-8BF5-23FFF9C23195.jpeg
    292.3 KB · Views: 30

Bigpanman

Novice Member
Joined
May 14, 2022
Messages
4
Reaction score
0
Points
1
Sk15
Driving
MG HS PHEV
Update on radio its going in for a new infotainment system next week under warranty
 
Support us by becoming a Premium Member

Latest MG EVs video

MG4 News + MG5 Pricing and Specification Announcements
Subscribe to our YouTube channel
Top Bottom