• We are having a problem with new Hotmail members being unable to receive activation emails. Please avoid using a Hotmail email address. Thanks.

MG4 XPower pet peeves…

Managed to get out on the A27 locally for another test of the vibration. There was something there but can't personally say it was too annoying (agree that on a long journey this opinion might change). The squeaky brakes in reverse got me told off when parking on the drive last night by the wife. I've initially put it down to only having <200 miles on the odo and will try to properly use the brakes forward & reverse later on a clear road. I found launch control worked with a firm stamp on the brake pedal most of the time, but yes maybe it does have hidden rules regarding how much % SOC or warmth of battery etc etc. Haven't really thrown it about in corners as still getting used to size/weight/tyres/brakes/OPD etc, but for most people I'm sure it will handle spot-on. The fogging on windscreen seems to resolve if you change the air to intake rather than recirculation on mine anyway.
 
I'm really getting quite fed up of having to look back at the car when I lock it and walk away.
Also really quite iritatted with how little it is costing me to own and run.
Absolutely furious yesterday, when I was flying past slower traffic on my way to Aberystwyth for fish and chips.
Nom.
 
Last edited:
Absolutely furious yesterday, when I was flying past slower traffic on my way to Aberystwyth for fish and chips.
I'd have to put an oar out the window to row mine along overtaking when the battery is as cold as it is now. Won't give me more than 68% power when it's cold, takes longer to warm up than any ICE car I've owned when battery heating is on. 😆

Struggled to overtake a Volvo estate yesterday on an uphill dual carriageway. Wouldn't even had to drop out of 6th gear in my last car to slip by. I reckon in its current state from 40mph it’s about as fast as the 1.2 TSI Ibiza I had donkeys years ago that I bought as a cost-saving exercise, and that thing was miserable.

I wouldn't mind so much if there was some sort of light/warning on the dash that it wasn't giving me the full beans, I can drive around it.

It’s going to be -4° tonight, so not looking forward to my Saturday journey.
 
Last edited:
I'm really getting really quite fed up of having to look back at the car when I lock it and walk away.
Also really quite iritatted with how little it is costing me to own and run.
Absolutely furious yesterday, when I was flying past slower traffic on my way to Aberystwyth for fish and chips.
Nom.
Its clearly making your life a living hell……
 
I'm really getting really quite fed up of having to look back at the car when I lock it and walk away.
Also really quite iritatted with how little it is costing me to own and run.
Absolutely furious yesterday, when I was flying past slower traffic on my way to Aberystwyth for fish and chips.
Nom.
I feel your pain too my friend. I’m thinking of blasting off tomorrow just to use a watt or two to cheer me up.
 
I'd have to put an oar out the window to row mine along overtaking when the battery is as cold as it is now. Won't give me more than 68% power when it's cold, takes longer to warm up than any ICE car I've owned when battery heating is on. 😆

Struggled to overtake a Volvo estate yesterday on an uphill dual carriageway. Wouldn't even had to drop out of 6th gear in my last car to slip by. I reckon in its current state from 40mph it’s about as fast as the 1.2 TSI Ibiza I had donkeys years ago that I bought as a cost-saving exercise, and that thing was miserable.

I wouldn't mind so much if there was some sort of light/warning on the dash that it wasn't giving me the full beans, I can drive around it.

It’s going to be -4° tonight, so not looking forward to my Saturday journey.
To be honest, I set off with 92% because I learnt my lesson the other day.....

 
To be honest, I set off with 92% because I learnt my lesson the other day.....

I set off much higher than that an had the same issue, so going to rule one temperature with a balance charge that should finish around lunchtime today, and then leave the car overnight.
 
My pet peeves just under three weeks in:
  • Drivers door doesn't shut very well - you have to really slam it, not something I'm used to
I think this is characteristic of the car - mine all want a fair slam.
  • Windows fog up really badly - no matter how you faff with the climate control - rear as bad as the front too
I don't have this at all, provided you have the air conditioning on and it set to vent to the windows, it should clear quickly and stay clear. If you've tried everything sounds like there is a fault.
  • Automatic braking when reversing into parking spaces is way too sensitive - it brakes when people get too close and they're along side the front quarter of the car
I haven't ever experienced this, unless it is an XPower specific thing?

  • Temperature sensor calibration on the climate control is +5ºC out, if not more - but the app reports it correctly 🤷‍♂️
Yep, has always been this way, no idea why this has never been fixed.
  • Brakes squeak badly
Mine are silent - but then the XPower has a different system. Might need to bed in?
  • Tyres are absolute bobbins - then again my last car had Michelin Pilot Sport 5 on it and the previous one had Cup 2.
    • They cause understeer on higher speed roundabouts (yes, within the speed limit)
    • Lifting off to slow down makes the back then go twitchy
    • Throttling back on to correct doesn't work very hot-hatch like (again, I do consider it more a EV Muscle Car so I suppose that tallies)
It comes with premium tyres, not performance tyres, so they won't compare well. I suppose it is just cost cutting but it is a shame.

  • Forgetfulness of all the settings - not just drive modes, includes temperate and other things
Yep.
  • CarPlay randomly selects a side to put the UI on - can change while you're driving
Rumours of this being fixed in R46.
  • If you turn the function on to show blind spots at junctions it freaks out when using CarPlay and the screen just goes black
Never tried that!
  • USB port is really funny about cables - even brand new official Apple cables can sometimes cause an issue where CarPlay doesn't work
I can recommend Anker braided cables, they work reliably.
  • Steering isn't bad, but it's totally 'inert' I'm just used to more feeling, adding weight in sport mode doesn't improve this, just makes it heavier
    • Previous car also had electric steering but it was lovely - you could feel the white lines in car parks at low speed
    • It's direct enough, and as long as it isn't wet the car will turn nice enough
Quite a few have said this - mine isn't inert (but it also isn't buzzing with information) but I don't know what changes having a front motor brings in.

  • Sometimes you turn the heated seats and wheel on and then within a few seconds it turns them off again - and then you're wondering why your bum isn't getting warm
Not had this bug.

  • Automatic light dipping is awful, but then the only car I've had that worked well for this was a Merc
Mine works ok, as good as most cars I have had but never had a Merc.

  • 'Automatic' wipers (as referred to in the manual) aren't actually automatic - years and years ago I had a 206 GTi from 2000 that had proper automatic wipers 😆
Yes, I prefer these speed-sensitive ones, more predictable than auto ones that frustrate me.
  • How long the infotainment screen takes to boot - even if you've been in and out of the car quickly
Yes, bit slow.
  • I'm sure the app was designed by someone who's never used one before - things are all over the place - and I can't extract the key from the Android version using an emulator as it needs Android 8.0 or higher to run, so I can't use mitmproxy to sniff it out and build my own app
Could indeed be better, but at least we have one.

I have to say, I've had worse, mostly from VW Group cars (looking at you SEAT!) But all the same, they annoying.
Snap.
Despite all that it is just more relaxing than any other car I've owned - and my heart is probably grateful for the lower blood pressure.
That's good to hear. 👍
 
New pet peeve, although I can work around it… the screen washer fluid bottle is a bit small. Last four cars have managed to hold around 4 litres. Just means I’m already filling it up three weeks in, but that’s fine, I need to be mindful of checking it every so often. Also not having a levels sensor for it is something I’m not used to either. It’s fine, just didn’t expect it to drain so quickly.

I live out in the county, so the roads are filthy so it gets used a lot.
 
New pet peeve, although I can work around it… the screen washer fluid bottle is a bit small. Last four cars have managed to hold around 4 litres. Just means I’m already filling it up three weeks in, but that’s fine, I need to be mindful of checking it every so often. Also not having a levels sensor for it is something I’m not used to either. It’s fine, just didn’t expect it to drain so quickly.

I live out in the county, so the roads are filthy so it gets used a lot.
Yes, it is small.
 
Almost 500 miles in and all going well (mainly). I have the 65+ vibration but not a major issue for me at the moment as most driving is below that speed. Annoying brakes screeching in reverse only. Other than that, I'm very happy. I spend 10secs each drive quickly changing LKA to middle option (not emergency lane change), Front Collision to alert only and OPD on. Mainly using heated seat & s/wheel with HVAC to clear windows if required. Average is currently 2.8 ml/kWh. I'm driving normally for me, fast when needed, relaxed otherwise but not planning to lose licence just because it can beat a lot of cars.
 
One thing which I've now experienced twice is it picking up a "speed sign" from the back of a lorry. Once it bumped up to 60 in a 50 average speed camera zone, the other down to 20 in a 40! Obviously I won't be using that again... manual speed limiter from now on.
 
Also, it sees speed limits that do not apply to it.

There's a thread somewhere about the windows fogging up. It's a problem a number of people have complained about, but which others (including me) swear they never encounter.
 
Also, it sees speed limits that do not apply to it.

There's a thread somewhere about the windows fogging up. It's a problem a number of people have complained about, but which others (including me) swear they never encounter.
Not had the issue personally but have noticed that the HVAC reverts to internal circulation mode frequently so I change it to arrow into car/external circulation and seems to do the job fine.
 
Well from tomorrow I will probably, but hopefully not, contribute.
Car has been in my garage since delivery last Friday, WHAT I hear you say. As mentioned previously been away in Yorkshire last week and used the EV6 instead, which I have just been washing in the rain ready for collection tomorrow! Neighbours must think Im an idiot, so do I…

One thing I can say is that setting off peak charging through the app worked. Charged to 80% on the 1st December then to 100% last night, so happy with that. Will try setting through car next time to see if that works.
 
Two things still irritate me:
  1. Approaching a car in front while in cruise control; part-way through the 'mirror-indicator-manoeuvre' thing and the car takes its foot off the gas.
  2. Random, unexpected steering tugs while the car follows phantom road markings.
 
Support us by becoming a Premium Member

Latest MG EVs video

New EVs from MG: MG S9 & MG9 plus hot topics from the forums
Subscribe to our YouTube channel
Back
Top Bottom