No heating

iainfm

Active Member
Joined
Aug 5, 2021
Messages
140
Reaction score
100
Points
43
Dumbarton
Driving
MG5
Hi, hope everyone had a great Christmas!

Drove across the country to visit relations today. 100% charge before I set off, but no heating on any setting at all. Which was a bit chilly as it's only 3degC outside!

Got here safe, and hoping it'll miraculously sort itself before the return trip.

Any other suggestions other than crossed fingers?
 

charles

Standard Member
Joined
Dec 22, 2021
Messages
35
Reaction score
29
Points
18
Bournemouth
Driving
MG5
Hi, I've noticed the heating is a bit rubbish, bordering on non-existent when in Eco mode but in normal I've not had a problem.

Which mode were you in?
 

5teep

Well-known Member
Joined
Jun 29, 2021
Messages
794
Reaction score
680
Points
96
Cruising
Driving
MG5
Hopefully just a glitch, otherwise it's a trip to the dealer (
I had a weird one on Friday, for the first trip (1.5 hours) I had no Kers3, it just wouldn't allow me to set it. Next run it was just working again.
 

JCFlippen

Well-known Member
Joined
May 14, 2021
Messages
543
Reaction score
585
Points
93
Monmouthshire
Driving
MG ZS EV
Hopefully just a glitch, otherwise it's a trip to the dealer (
I had a weird one on Friday, for the first trip (1.5 hours) I had no Kers3, it just wouldn't allow me to set it. Next run it was just working again.
Did you charge to 100%? If so that combined with cold battery could contribute to the non Kerr’s feeling.
 

iainfm

Active Member
Joined
Aug 5, 2021
Messages
140
Reaction score
100
Points
43
Dumbarton
Driving
MG5
Hi, I've noticed the heating is a bit rubbish, bordering on non-existent when in Eco mode but in normal I've not had a problem.

Which mode were you in?
I was in eco, which has definitely given me heating before. I did try normal as well though.
 

iainfm

Active Member
Joined
Aug 5, 2021
Messages
140
Reaction score
100
Points
43
Dumbarton
Driving
MG5
Home safe, if a bit chilly. Had a play with the heating while watching the ammeter display (while parked) and it doesn't flinch when changing the temperature at all.

The other weird thing that happened was I saw the rear de-mist LED flashing very briefly for a while when it was turned off, but no idea if it's related.

So, a call to the dealer as soon as they open I guess. Hopefully it'll be something simple like a loose connector or something.

At least it didn't happen when the screen was frozen up completely!
 

Ozzie1989

Well-known Member
Joined
Oct 13, 2021
Messages
621
Reaction score
632
Points
93
Wales
Driving
MG5
Hopefully it'll be an easy fix and fairly simple.

In an ICE a cold blower (when it should be hot) would either be a simple valve to feed the matrix failed, cable/electronic control, a panic as the engine overheats because you've lost all your coolant or a knackered water pump, radiator, etc. etc. 🤣

Good thing about electric cars in theory if one part fails (that isn't the motor) you can carry on regardless - ice permitting in this case!
 

iainfm

Active Member
Joined
Aug 5, 2021
Messages
140
Reaction score
100
Points
43
Dumbarton
Driving
MG5
I had a very prompt response from the dealer, who said its a PTC (positive temperature coefficient, according to Google!l heater in these.

My understanding is they're (usually/often/sometimes) a ceramic heating element, so possibilities are/include a failed element, blown fuse, bad relay (or solid-state equivalent) or a bad connection...or something else.

I'll check the fuses later (I'm assuming it'll be one of the ones under the bonnet rather than the ones behind the dash*) but if not then it's a dealer job, and they're not open until the 5th.

I'm planning any major excursions, but it is a hassle - they're an hour away and I've just started a new job. Such is life though!

*Edit: According to the manual, it looks like F47 (5A) inside the cabin is the one to check
 
Last edited:

iainfm

Active Member
Joined
Aug 5, 2021
Messages
140
Reaction score
100
Points
43
Dumbarton
Driving
MG5
Fuse 47 is intact, so looks like it's getting a trip to the dealer in the new year!
 

iainfm

Active Member
Joined
Aug 5, 2021
Messages
140
Reaction score
100
Points
43
Dumbarton
Driving
MG5
My 5 has been in the dealer for nearly 4 weeks now, same problem, parts on back order eta late January
Jeezo. Has the dealer been helpful, eg given you a courtesy car while they have yours? Never had to deal with a new car warranty issue before, so unsure what to expect/demand!

While the weather's mild enough it's fine (it's certainly boosted my miles/kWh rating), but if it was to get colder there's no way I'd be able to keep the screen ice-free.
 

Bill Urquhart

Novice Member
Joined
Aug 20, 2021
Messages
3
Reaction score
2
Points
3
Drumnadrochit, highland
Driving
MG5
Jeezo. Has the dealer been helpful, eg given you a courtesy car while they have yours? Never had to deal with a new car warranty issue before, so unsure what to expect/demand!

While the weather's mild enough it's fine (it's certainly boosted my miles/kWh rating), but if it was to get colder there's no way I'd be able to keep the screen ice-free.
Running an mg3 courtesy car just now which barely manages 45 mpg, I live in the north of Scotland so demisting defrosting issues meant the car was unusable, part supply is a major issue just now, my dealer has four franchises and suffering problems with them all, they currently have in excess of 100 courtesy car/ demos out on loan, if your dealer cannot supply a car push them to authorise a hire car from MG
 

iainfm

Active Member
Joined
Aug 5, 2021
Messages
140
Reaction score
100
Points
43
Dumbarton
Driving
MG5
Thanks for that. I used to not live a million miles from you (Kirkhill near Beauly/Kiltarlity) :)

Which dealer is yours at? Might be worth mentioning to mine to save a bit of their time diagnosing the problem.
 

Bill Urquhart

Novice Member
Joined
Aug 20, 2021
Messages
3
Reaction score
2
Points
3
Drumnadrochit, highland
Driving
MG5
Thanks for that. I used to not live a million miles from you (Kirkhill near Beauly/Kiltarlity) :)

Which dealer is yours at? Might be worth mentioning to mine to save a bit of their time diagnosing the problem.
Dicksons Inverness, I have seen others with the same problem on forums on Facebook,
Parts ordered are a heater element and an electric valve, other than that I don’t know what exactly is wrong
 

5teep

Well-known Member
Joined
Jun 29, 2021
Messages
794
Reaction score
680
Points
96
Cruising
Driving
MG5
Running an mg3 courtesy car just now which barely manages 45 mpg, I live in the north of Scotland so demisting defrosting issues meant the car was unusable, part supply is a major issue just now, my dealer has four franchises and suffering problems with them all, they currently have in excess of 100 courtesy car/ demos out on loan, if your dealer cannot supply a car push them to authorise a hire car from MG
Ah, that's maybe why I cannot get a loaner. My car is in there for it's first service next week.
 

smokie

Well-known Member
Joined
Sep 9, 2021
Messages
1,068
Reaction score
812
Points
113
Wokingham, UK
Driving
MG5
Sorry about this, Going of on a tangent, does anyone get a smell of burning when first switching the heater/ demister on ????
Bodger - yes, I get an electrical burning smell, for maybe a minute or so. It only started doing it in the last couple of days (car is about 4 weeks old). I'll start a new thread about it.
 
Support us by becoming a Premium Member

Get your MG5 charging tee

Latest MG EVs video

MG electric car news and chat in our final podcast of 2022.
Subscribe to our YouTube channel
Top Bottom