• We are having a problem with new Hotmail members being unable to receive activation emails. Please avoid using a Hotmail email address. Thanks.

Android Auto not picking up my voice - Facelift 5.

Tweed98

Established Member
Joined
Jun 14, 2022
Messages
258
Reaction score
180
Points
69
Location
Essex
Driving
MG5
I've been swapped into a facelift 5 as my company car for the last 3 weeks and I love it. However, I think the microphone may be busted as Andriod Auto doesn't pick up my voice. I'm using the same phone that worked well with my old PFL5, everything else on AA works well, does anyone have any suggestions?

It has dawned on me that I haven't tried calling someone to see if the microphone is working at all!
 
Not sure whether this is of any relevance, or usefulness to you...

But, in my prefacelift 5, in recent weeks Android Auto has sometimes failed to "respond" to voice commands, especially when wanting to use Google maps for navigation. Often, waiting a few minutes and then trying again (by pressing the mic button on the steering wheel and then saying what I want the app to do) will succeed. On failed attempts, I hear AA "bleep" and the small screen opens at the bottom of the Google Maps screen (on which those voice commands should appear as text) but no words are "heard" or appear on that screen.

Since this problem has occurred only in recent weeks (when I first had the car voice commands were accepted and responded to almost immediately) I wonder whether an update to AA has caused it?
 
Not sure whether this is of any relevance, or usefulness to you...

But, in my prefacelift 5, in recent weeks Android Auto has sometimes failed to "respond" to voice commands, especially when wanting to use Google maps for navigation. Often, waiting a few minutes and then trying again (by pressing the mic button on the steering wheel and then saying what I want the app to do) will succeed. On failed attempts, I hear AA "bleep" and the small screen opens at the bottom of the Google Maps screen (on which those voice commands should appear as text) but no words are "heard" or appear on that screen.

Since this problem has occurred only in recent weeks (when I first had the car voice commands were accepted and responded to almost immediately) I wonder whether an update to AA has caused it?

Ahh, my Missus mentioned that it had been updated recently.
I'll see if it works tonight and check a few android forums.
 
I have a feeling the speech recognition is done on the Google servers - I think. If you've got a pants mobile data signal at the time, that might explain the lack of voice recog.
 
Pretty good 5g around work and 4g at home, definitely something to check the next time it doesn't work.
I don't use the voice control that much any more, now I get home before the wife, not much point texting to say I'm on my way!
 
Noticed similar on my pre-fl 5 voice commands were pretty good much worse recently. Also plug the phone in fail to connect more frequently in the last few weeks. Needing to reboot the entertainment unit after plugging in to get a connection.

Edit - thought while writing the above should clear the app cache as its updated recently. Did this and cleared app data. Reset up the connection. Its only a couple of go's but starting up ok and voice commands worked pretty fast. Maybe wishful thinking but perhaps a clean start is whats needed post updates.
 
Last edited:
I had some occasional connection issues with my old PFL and SEAT Leon but not regularly. Trouble is in the FL I think turning the car off and on again is the only way to reboot the entertainment.
 
I had some occasional connection issues with my old PFL and SEAT Leon but not regularly. Trouble is in the FL I think turning the car off and on again is the only way to reboot the entertainment.
Press and hold the home button for ~10seconds will reboot the system in the FL5.
 
Press and hold the home button for ~10seconds will reboot the system in the FL5.

Sweet! Thanks very much for the tip!

Latest update.

I tried using voice control again last night. I definitely had a signal but no recognition of it hearing me on the screen, then it shut off.

I tried OK Google to see if my phone could hear me and the car blipped and the speech recognition bar appeared on the screen but didn't hear me after the wake word. My phone didn't react so no idea if it heard me or the car heard me.

I tried a Bluetooth call and the other person also couldn't hear me, but I could hear them so definitely connected. They called back twice and couldn't hear me when I answered.

Edit - thought while writing the above should clear the app cache as its updated recently. Did this and cleared app data. Reset up the connection. Its only a couple of go's but starting up ok and voice commands worked pretty fast. Maybe wishful thinking but perhaps a clean start is whats needed post updates.

Have just deleted the stored file and the cache. Will probably have to set it all up again but I figure as near as a new install as possible can't hurt.

1698759450128.png


I also went into the app permissions in case the microphone was switched off and saw this. As you can see the Microphone hasn't even been accessed even though on the page a bit lower down the phone was accessed. Curious and Curiouser!
 
As you can see the Microphone hasn't even been accessed even though on the page a bit lower down the phone was accessed. Curious and Curiouser!
Android Auto is using the car’s microphone and speaker, that’s probably why there was no access to the phone’s mike?
 
Android Auto is using the car’s microphone and speaker, that’s probably why there was no access to the phone’s mike?
That's what I thought, but something definitely hears me say OK google and brings up the speech recognitions pop up. I'm certain that this is an android problem as the forums seem to have so many complaints of this.

I tried resetting the cache and even the storage, so a soft reset to manufacturer settings on AA and that didn't help. Although playing through the settings let me find the option for decreasing the brightness of the screen, so much better than the PFL, I'm not getting dazzled at night.

I think I may go nuclear and uninstall then reinstall AA and if that doesn't work down load an old APK of AA.
 
That's what I thought, but something definitely hears me say OK google and brings up the speech recognitions pop up

How are you "activating" the voice commands facility?

In my case, it's pressing the "headset" button on the steering wheel, RHS, that opens that speech recognition pop-up. I've never tried just speaking without first pressing that button.
 
How are you "activating" the voice commands facility?

In my case, it's pressing the "headset" button on the steering wheel, RHS, that opens that speech recognition pop-up. I've never tried just speaking without first pressing that button.

The action button on the steering wheel or shouting OK Google, both of which worked fine until last week.

Update:

My car has been with Glyn Hopkins in Chelmsford for 9 days so far.

Upside is they gave me a HS as a courtesy car. Its quite nice, it has dual climate control, a massive sunroof, courtesy lights and a nice ride. The downside is the rear seats are as black as coal at night and it has a petrol engine! Other than that very similar software-wise, gizmos and trim to the pre-facelift 5. Oh and it being high is a godsend for my buggered knee, I can get the boy in his seat really easily and it the only car I've been able to get in with dignity since boxing day!

Oh I got the fleet team to plug their phones in to see if it was just mine/android. It wasn't
 
Support us by becoming a Premium Member

Latest MG EVs video

New EVs from MG: MG S9 & MG9 plus hot topics from the forums
Subscribe to our YouTube channel
Back
Top Bottom