Waze lag using adroid auto in mg ehs

Yvesvdb1986

Standard Member
Joined
Feb 14, 2022
Messages
11
Reaction score
4
Points
3
Belgium
Driving
MG HS PHEV
Hello,

I recently aquired an mg ehs. Everything is fine with the car but when i use waze in adroid auto the problems start. The vocal messages arrive at the correct time but there seems to be a delay to the screen. Anyone else has this problem? And is there a solution?
 
Last edited:

Jto

Active Member
Joined
Aug 15, 2021
Messages
504
Reaction score
221
Points
46
Elstree
Driving
MG HS PHEV
I had the same type of problem with my IPhone so went over to Tom Tom no problems now.
 

djenson

Active Member
Joined
Nov 29, 2021
Messages
138
Reaction score
100
Points
43
UK
Driving
MG HS PHEV
I believe this is due to an inherent flaw with using waze with AA - Google maps grabs GPS data from the cars large and accurate GPS sensor, Whereas Waze uses your phones much smaller and less accurate sensor. This is why some people with expensive flagship phones may have no issue, but sometimes less expensive phone that skimp on the GPS sensor will have issues. ALso to do with general GPS satellite availability and strength in your area.
 

Yvesvdb1986

Standard Member
Joined
Feb 14, 2022
Messages
11
Reaction score
4
Points
3
Belgium
Driving
MG HS PHEV
I believe this is due to an inherent flaw with using waze with AA - Google maps grabs GPS data from the cars large and accurate GPS sensor, Whereas Waze uses your phones much smaller and less accurate sensor
But why only with this car? With all my other cars it works fine.
 

djenson

Active Member
Joined
Nov 29, 2021
Messages
138
Reaction score
100
Points
43
UK
Driving
MG HS PHEV
But why only with this car? With all my other cars it works fine.
The MG could have some sort of interference or signal blocking properties that weaken the GPS even more. Download a GPS testing tool like GPS Test and see what the strength in like In/Out of the MG. Put the phone in the place it would be when using AA, and plug in the car charger if you have one. This will give a worse case situation.
 

Yvesvdb1986

Standard Member
Joined
Feb 14, 2022
Messages
11
Reaction score
4
Points
3
Belgium
Driving
MG HS PHEV
The MG could have some sort of interference or signal blocking properties that weaken the GPS even more. Download a GPS testing tool like GPS Test and see what the strength in like In/Out of the MG. Put the phone in the place it would be when using AA, and plug in the car charger if you have one. This will give a worse case situation.
Ok thx
 

djenson

Active Member
Joined
Nov 29, 2021
Messages
138
Reaction score
100
Points
43
UK
Driving
MG HS PHEV
Just to follow up on using GPS test. Your looking for a SNR in the green area, and an accuracy as close to +-0 meters as possible. A low SNR will mean the GPS is susceptible to dropping out completely, where as low accuracy will mean the car may lag behind. see this screenshot, this is from my cheep Nokia 5.3 with a bad GPS signal
 

Attachments

  • Screenshot_20220216-124651.png
    Screenshot_20220216-124651.png
    96.9 KB · Views: 53

Yvesvdb1986

Standard Member
Joined
Feb 14, 2022
Messages
11
Reaction score
4
Points
3
Belgium
Driving
MG HS PHEV
Just to follow up on using GPS test. Your looking for a SNR in the green area, and an accuracy as close to +-0 meters as possible. A low SNR will mean the GPS is susceptible to dropping out completely, where as low accuracy will mean the car may lag behind. see this screenshot, this is from my cheep Nokia 5.3 with a bad GPS signal
Signal is the same in and out of the MG. I think the problem is with waze
 
Last edited:

FNMustangGTC

Novice Member
Joined
Jan 19, 2022
Messages
4
Reaction score
2
Points
3
Sydney, AUSTRALIA
Driving
MG HS PHEV
I've seen this as well on a relatively decent phone (Pixel 5). My 'fix' is to switch to one of the other screens via the Home/Car/HVAC buttons, and then back to Android Auto using the * button on the steering wheel. This seems to bring Waze back into sync .. for a while. Rinse and repeat.
 

Henri8

Active Member
Joined
Jan 6, 2021
Messages
137
Reaction score
39
Points
31
Naarden The Netherlands
Driving
MG HS PHEV
The fact is, as stated before, that the Waze voice commands exactly follow the position of the car while the screen lags behind, increasing with time. To me this rules out GPS problems.
 

djenson

Active Member
Joined
Nov 29, 2021
Messages
138
Reaction score
100
Points
43
UK
Driving
MG HS PHEV
The fact is, as stated before, that the Waze voice commands exactly follow the position of the car while the screen lags behind, increasing with time. To me this rules out GPS problems.
You do make a valid point there I hadn't considered. This with FNMustang's comments about 'refreshing' android auto seems to possibly point to some sort of overfilled frame buffer or rendering latency?? It isn't a issue that's just affecting MG though, heck, just google "waze android auto lag" and there's pages of google support pages, reddit threads eta all describing a similar issue.
 

ShinZ

Novice Member
Joined
Oct 20, 2021
Messages
2
Reaction score
0
Points
1
France
Driving
MG HS PHEV
Hi guys !
I have this problem too sometimes.
I solve it by simply restarting my phone.
I also observed that the problem can be more redondant with some version of waze so, upgrade or downgrade depending if last version is worst.
 

Melalon

Novice Member
Joined
Apr 17, 2022
Messages
1
Reaction score
0
Points
1
Israel
Driving
MG HS PHEV
To my observation, the delay in graphicc interface is caused due to constant graphics refreshing (data transfer), applicable to all navigation software. My remedy is to put the navigation work in the background (as voice alerts always come in a timely manner), and look on the map only when i really need it. It reduces the "traffic" of data through AA, and allows the system to remain responsive when needed. Obviously - good enough for now, until fixed...
 

kafman

Novice Member
Joined
Aug 6, 2022
Messages
2
Reaction score
0
Points
4
Costa Rica
Driving
MG HS PHEV
Hello,

Just want to add my two cents on this issue:
First all, apologies, as I do not use the MG HS PHEV, I live in a country where the only electrical model was the ZS, my HS 2022 is petrol.
Second, I have exactly the same issue as you guys, the local MG agency says that they do not have an update on the infotainment software. So I registered on the Waze beta software forums, it seems that the issue affects a lot of cars of other brands.

I know this is a bit tedious, but I strongly encourage the affected owners to make a Waze beta account on their forums and upvote the issue, so that Waze staff starts fixing this issue soon. As others have said, this issue only affects Waze, as using Google Maps or any other NAV software, works well.

Here's that thread: BUG-11776
 
Support us by becoming a Premium Member

Latest MG EVs video

MG4 News + MG5 Pricing and Specification Announcements
Subscribe to our YouTube channel
Top Bottom